Makro in allen Dateien verfügbar machen

Dazu müssen Sie Ihre Excel-Datei mit dem Makro als Add-In speichern. Führen Sie den Befehl “Datei | Speichern unter” aus und wählen Sie im Kombinationsfeld “Dateityp” die Einstellung “Microsoft Excel-Add-In”. Geben Sie einen Namen für die XLA-Datei ein und speichern Sie diese. Jetzt müssen Sie das soeben erzeugte Add-In für Excel verfügbar machen. Wählen Sie “Extras | Add-In-Manager” und klicken Sie auf “Durchsuchen”. Dort markieren Sie das zuvor erzeugte Tool und klicken auf “OK”. Prüfen Sie nun in der Liste der verfügbaren Add-Ins, ob das Kontrollkästchen vor dem neuen Add-In aktiviert ist. Mit einem letzten “OK” stehen die darin enthaltenen Makros künftig bei jedem Start von Excel zur Verfügung. Über dasselbe Menü können Sie das Add-In auch wieder deaktivieren

Es befindet sich unter:

C:\Users\Benutzername\AppData\Roaming\Microsoft\AddIns

http://officewissen.net/makros-fuer-alle-excel-dateien-verfuegbar-machen/

Ein Makro wird global verfügbar wenn dieses in einer Arbeitsmappe
Personl.xls im Verzeichnis XLStart gespeichert wird.
Meist sinnvoll dies mittels Fenster-Ausblenden unsichtbar zu machen

Excel: Funktion/Makros in allen Arbeitsmappen benutzen
http://support.microsoft.com/kb/508700

Excel VBA Wert von Spalte A und Spalte B in C zusammenführen

Vorname Nachname Name
Andre Cehnier Andre Cehnier
Frank TheTank Frank TheTank
Opel VW Opel VW
Renault Clio Renault Clio

Excel Sverweis

SVERWEIS(Suchkriterium;Matrix;Spaltenindex;Bereich_Verweis)

  • Suchkriterium ist der Wert den ich suche – mehr dazu später
  • Das Argument Matrix ist der Bereich also B5:E8 wo durchsucht wird
  • Spaltenindex ist der Wert, der zurück gegeben wird, wenn gefunden
  • Wobei erste Merkregel: Spaltenindex ist immer zu zählen ab der Position der Suchspalte und ist unabhängig davon, wo mein Suchbereich beginnt!
  • Durch die Angabe des vierten Argumentes mit Falsch wird erwirkt, dass genau nach dem Suchwert gefahndet wird.

http://www.online-excel.de/excel/singsel.php?f=9

=WENN(ISTNV(SVERWEIS(A2;’geprüft!A:A;’geprüft!A:A;FALSCH));“ „;SVERWEIS(A2;’geprüft‘!A:A;’geprüft!A:A;FALSCH))

Doppelpunkt zu MAC-Adresse hinzufügen:

  • =LINKS(A2;2)&“:“&TEIL(A2;3;2)&“:“&TEIL(A2;5;2)&“:“&TEIL(A2;7;2)&“:“&TEIL(A2;9;2)&“:“&RECHTS(A2;2)

Substring k9 Suchen, wenn gefunden wird SSH geschrieben, sonst Telnet

  • =WENN(ISTZAHL(SUCHEN(„k9″;C2));“SSH“;“Telnet“)